Announcement: Errors Encountered in ArcGIS Server and Portal for ArcGIS Web Apps after Certain Browser Updates

02/06/2017 Update: Patches have been released for Portal for ArcGIS version 10.3 and 10.4, which can be found here. We are continuing to work on patches for ArcGIS Server Manager (10.2.x, 10.3, and 10.4) and Portal for ArcGIS (10.2.x). We appreciate your patience as these patches are being developed.

11/23/2016 Update: Patches have been released for ArcGIS Server version 10.3.1 and 10.4.1, which can be found here. We are continuing to work on patches for ArcGIS Server Manager (10.2.x, 10.3, and 10.4) and Portal for ArcGIS (10.2.x, 10.3, and 10.4). We appreciate your patience as these patches are being developed.

11/10/2016 Update: Patches have been released for Portal for ArcGIS versions 10.3.1 and 10.4.1, which can be found here. We are continuing to develop patches for ArcGIS Server Manager (10.2.x, 10.3.x, and 10.4.x) and Portal for ArcGIS at version 10.2.x, 10.3, and 10.4.

The forthcoming updates to the Firefox, Chrome, and Safari browsers cause errors in some web applications for ArcGIS Server and Portal for ArcGIS when users upload content.

The following browser versions are affected:

  • Firefox 49 (Release Date: September 20, 2016)
  • Chrome 54 (Release Date: October 18, 2016)
  • Safari 10 (Release Date: September 20, 2016)

Note: Microsoft Internet Explorer and Microsoft Edge are not affected.

The following ArcGIS products are affected:

  • ArcGIS Server 10.2.x, 10.3.x, and 10.4.x (patch deployed on 11/14/2016 for ArcGIS Server 10.3.1 and 10.4.1)
  • Portal for ArcGIS 10.2.x, 10.3, and 10.4 (patch deployed on 12/16/2016 for Portal for ArcGIS 10.3, 10.3.1, 10.4 and 10.4.1)
  • The ArcGIS API for JavaScript (patch deployed on 9/19/2016 for versions 3.11 and above.

The following workflows are affected:

Portal for ArcGIS Home Application

  • Updating details for any content, such as items within “My Content” or fields within a user profile
  • Creating new groups via “Groups” > “Create A Group”
  • Uploading content via “My Content” > “Add Item” > “From my computer”
  • Uploading content to the Portal for ArcGIS Map Viewer via “Add” > “Add Layer from File”
  • Adding attachments when editing features in the Portal for ArcGIS Map Viewer
  • Updating thumbnails on any Item Details page or via “My Organization” > “Edit Settings” > “General”
  • Updating the banner or background images via “My Organization” > “Edit Settings” > “Home Page”

Below is an example of the error encountered when attempting to upload content in the Portal for ArcGIS home application.

An example of the error which can be seen when trying to upload content to the Portal for ArcGIS Home App

This example shows the error which can be seen when trying to upload content to Portal for ArcGIS

ArcGIS Server Manager

  • Uploading service definitions (SD) when publishing services
  • Uploading SDE database connection files when registering a database as a data store
  • Uploading SOE or SOI files when adding extensions
  • Uploading KMZ files

Below is an example of the error encountered when attempting to upload an SD in ArcGIS Server Manager.

An example of the error seen when uploading content to ArcGIS Server Manager

This example shows the error seen when uploading content to ArcGIS Server Manager

To resolve these errors, Esri is developing software patches for ArcGIS Server and Portal for ArcGIS. We will keep you informed as the patches become available.


Thomas E. – User Advocacy

This entry was posted in Announcements, ArcGIS for Server, High Priority and tagged , , , , , , , , , . Bookmark the permalink.

Leave a Reply

17 Comments

  1. esri4591 says:

    Do we have any update about the patch ?

    • Thomas Edghill says:

      Hello esri4591, thank you for your question. Development of these patches are still underway, and this blog will be updated with more details as they are available. We appreciate your patience as we work on addressing these errors.

  2. Nick Miller says:

    Can I ask if users are experiencing other errors within Portal using Chrome and Firefox other than those issues listed above?

    • Thomas Edghill says:

      Hello Nick, there is an additional issue which was discovered, related to creating groups in Portal for ArcGIS when using Chrome and Firefox at the versions defined above. This finding has been added to the blog content.

      If you believe to have found any other issues which should be reported, we encourage that you reach out to Esri Support Services so that we can investigate further. Thank you!

  3. cgishack says:

    We are experiencing these issues in Portal for ArcGIS.
    Is there a patch yet?

  4. pdavidson says:

    I have also had a problem with Chrome 54 and trying to add a server, or after adding a server, having it show up as not being connected or other odd results.
    This is in My Organization>Edit Settings>Servers>Add Servers

    I spent a couple of hours with Professional Services working on this before it was a known problem. We were trying to track down the Add Item issue reported above and the Servers box was showing a disconnected server, that really wasn’t disconnected, except sometimes in some ways via Chrome.
    We eventually snapped to the issue being Chrome and switched to IE, un-federated the server, re-federated it and all was well. Uploads started working and the server even shows up in Chrome correctly now.
    I have relegated Chrome to the ash heap for Portal work, at least for now.
    I did not report this to tech support because I can no longer duplicate the problem.

  5. spt_jfp says:

    Are there official Esri Bug Numbers for these – is so what are they?
    Thank you

    • Thomas Edghill says:

      Yes, there is an official bug which is logged for this. At the moment we are keeping track of all of the issues under a single bug number. We are currently working on making this bug show up in the Support Site, but for reference the bug number is: BUG-000099447.

      • Thomas Edghill says:

        I have a slight correction to my previous comment. There is an official bug logged for Portal, and one logged for Server Manager, although both of these bugs will be used to track all issues discovered for each web app.

        The bug number for Portal: BUG-000099447
        The bug number for Server Manager: BUG-000099629

        We are continuing to develop a patch, and will be posting updates as soon as more arise. Thank you.

  6. mruch says:

    I am receiving the same type of error when attempting to edit item details for any item in Portal using Chrome 54.

    • Thomas Edghill says:

      Thank you, this was also discovered through internal testing here, as well as similar issues with updating any information in a user profile. We will work on updating the blog details with this information.

  7. Thomas Edghill says:

    I would like to leave an update here to say that a patch has been released for Portal for ArcGIS 10.3.1 and 10.4.1. The patch can be downloaded from the following link:

    http://support.esri.com/Products/Server/portal-for-arcgis/portal-for-arcgis/10-4-1#downloads?id=7450

    The blog is being updated to reflect this new information. We appreciate your patience as we continue to develop patches and release them for the other products and versions.

  8. randallwilliams says:

    After applying these patchs, be sure to clear your temporary internet files!!

    • mvolz47 says:

      Does the patch for ArcGIS for Server cover the bug with the Server Manager Statistics Report checboxes for services no longer working as discussed in below thread:

      ArcGIS Server Manager: Statistics Page CheckBox Error Chrome 54, 55