ArcGIS API for Flex and ArcGIS Viewer for Flex: Version 2.4 released

Versions 2.4 of both the ArcGIS API for Flex and ArcGIS Viewer for Flex were released today. Many improvements have been made, especially to the viewer, so take a careful look at What’s New in the API and What’s New in the Viewer. Here are the Top 10 new viewer and API highlights of the 2.4 releases:

ArcGIS Viewer for Flex 2.4

  1. New Geoprocessing widget that works with almost any geoprocessing task.Geoprocessing widget
  2. Clustering of points from feature layers. See layer tag.Clustering in the Flex Viewer
  3. You can configure a definition expression on sublayers within a layer of type=”dynamic” (an ArcGIS Dynamic map Service). See layer tag.
  4. You can set a widget size in the configuration file.
  5. KML layers introduced. The <layer> tag supports type=”kml”.
  6. Support for four new locales has been added: Arabic, Brazilian Portuguese, Italian and Russian. This is in addition to the existing locales of Chinese, English, French, German, Japanese, and Spanish.Arabic bookmark widget
  7. The initial “view” of the Search and Locate widget can be set in the widget configuration file.
  8. Improved compatibility with Adobe Flex 4.5 SDK.
  9. Widgets can be centered using new verticalcenter and horizontalcenter.
  10. Bug fixes:
    • Color of hyperlinks in popup windows remain the same even after clicking the link
    • Multiple bug fixes related to widget layout locations and run-away widgets. Widgets can be place anywhere even when the overview map widget is open. Floating and vertical layouts don’t experience run-away widgets.
    • Overview map widget can be placed in any corner

For the full list of viewer enhancements, view the What’s new in 2.4 help topic.

ArcGIS API for Flex 2.4

  1. KML Layer gives easy access to data in KML format.
  2. Support for four new locales has been added: Arabic, Brazilian Portuguese, Italian and Russian. This is in addition to the existing locales of Chinese, English, French, German, Japanese, and Spanish.
  3. Improved support for mobile and touch-aware applications:
    • Improved pinch with interactive resizing.
    • New spark-based slider for the Navigation zoom slider.
    • No pan cursor if device doesn’t support a cursor.
  4. Improved compatibility with Adobe Flex 4.5 and 4.5.1 SDK.
  5. Improved clustering with the cluster symbol size able to be changed based on the number of features in each cluster.
  6. Expanded WMS functionality.
  7. InfoWindow fires an OPEN event when opened.
  8. Bug fixes for dates in the AttributeInspector.
  9. Bug fixes for Editor related to eliminating unnecessary requests.
  10. Bug fix for file sizes with the AttachmentInspector.

View the What’s new help topic on the ArcGIS API for Flex resource center for full details.

Contributed by Bjorn Svensson of the ArcGIS API for Flex development team

This entry was posted in Services and tagged , , . Bookmark the permalink.

Leave a Reply

5 Comments

  1. mountshd says:

    Where do I download the viewer 2.4?

    Thanks,

    Heather

  2. dcopple says:

    How do you load kml in the confic.xml file?

    Thanks,
    Don

  3. bjorn says:

    @Heather et al, to download the Flex Viewer, go to the resource center at http://help.arcgis.com/en/webapps/flexviewer/, click the “Download Viewer” link on the right side of the page (under Quick Links).

  4. bjorn says:

    @gtuchristina,
    To upgrade your viewer from 2.3.1 to 2.4 you will have to recompile your application. Sorry.

    Note that as of version 2.4 of the Viewer, Adobe Flex 4.1 SDK is the minimum SDK version to compile with. This is to support Arabic and other right-to-left locales. Adobe added RTL support for in 4.1 which we are taking advantage of. Note that the API itself still works with 4.0, 4.1 as well as 4.5 (but that the Viewer require 4.1 or above).

    http://help.arcgis.com/en/webapps/flexviewer/help/index.html#/What_s_new_in_2_4_Viewer/01m300000011000000/

    http://help.arcgis.com/en/webapps/flexviewer/help/index.html#/Upgrading_your_Viewer_code/01m30000001m000000/

  5. blespa says:

    Hi everybody,

    I am Blerina from Albania, and i have translated the Flex Viewer 2.4 in Albanian language. I want to share this with the community. Where can i upload the .zip file?

    Regards,
    Blerina